[ts-general] Problem(s) 403 and 524 - shim..start - possible fix

Harry Balzer harry.balzer at yahoo.com
Wed Sep 5 08:58:45 EDT 2012


paul has been a big help to me as well.

i've built a text of specific instructions to get the shim running with the latest tws and centos distributions
and will post it when i confirm paul's fix worked for me as well.  here's what i've got prior to the patches.
maybe compare it to your findings, and we can start one consolidated thread that's easy to find (HOW TO
CONFIGURE) or something.


mkdir temp
cd temp
wget -q \ ftp://ftp.trading-shim.org/pub/local/trading-shim/shim-100416.tgz
tar zxf shim-100416.tgz
wget -q \ ftp://ftp.trading-shim.org/pub/local/trading-shim/data-100331.tgz
cp data-100331.tgz shim-100416
cd shim-100416
tar zxf data-100331.tgz
rm -f sym
ln -s data-100331 sym
ls -al
ls sym


edit etc/my.cnf  (serializable, innodb):
[mysqld]
...
transaction-isolation=SERIALIZABLE
innodb_lock_wait_timeout=120
innodb_autoinc_lock_mode=0


edit setup.sql (mys/risk.sql)
edit tables.sql (mys/<files>.sql)
edit A0 files in /shim/data ('desc' to 'text')


any changes to my.cnf run this to implement:

/etc emacs my.cnf (as root user -- su root, followed by password)
/var/lib service mysqld restart


checking sql database:

select * from Template;


tws, add alias to /root/.bashrc and /home/user/.bashrc:

alias tws='java -cp jts.jar:hsqldb.jar:jcommon-1.0.12.jar:jfreechart-1.0.9.jar:jhall.jar::KSother.jar:rss.jar -Xmx512M jclient.LoginFrame .'

alias tws='java -cp jts.jar:hsqldb.jar:jcommon-1.0.12.jar:jhall.jar:other.jar:rss.jar -Dsun.java2d.noddraw=true -Xmx512M ibgateway.GWClient .'

lsof -i:7496   (should confirm ftp listener on port)

in tws, edit -> global configurations -> api -> settings:
enable activex and socket clients
socket port 7496
create -> trusted ip address -> 127.0.0.1

copy shimrc:
cp shimrc .shimrc
emacs .shimrc
let DbmsHost = localhost,
FeedHost = twshost,
ApiLevel = 47;

as root user, edit etc/hosts adding twshost to 127.0.0.1:

127.0.0.1 localhost twshost localhost.localdomain localhost4.localdomain4

<patches>


________________________________
 From: John Cawley <uidentzero at gmail.com>
To: ts-general at mail.trading-shim.org 
Sent: Tuesday, September 4, 2012 8:03 PM
Subject: Re: [ts-general] Problem(s) 403 and 524 - shim..start - possible fix
 

Paul,

i can confirm that your fix worked for me and shim-101126 is running in x64 CentOS 6.3.  Was your contribution made as a user, or do you have an "official" role supporting the shim?  Either way, thank you.


Another question: between the mailing list archives, Google, and your posts I was able to address the half dozen or so tweaks needed to get it running.   Has anyone put those changes in one post?  I'll offer if it hasn't already been done.

Regards,

John


_______________________________________________
ts-general mailing list
ts-general at lists.trading-shim.org
http://www.trading-shim.org/mailman/listinfo/ts-general
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.trading-shim.org/pipermail/ts-general/attachments/20120905/d80fbd56/attachment.html 


More information about the ts-general mailing list